MC Championship - MCC+ players not receiving daily gems – Incident details

MCC Island Minecraft Server under maintenance

MCC+ players not receiving daily gems

Resolved
Degraded performance
Started 11 days agoLasted 1 day

Affected

MCC Island Minecraft Server

Degraded performance from 9:00 AM to 3:48 PM

Updates
  • Resolved
    UTC
    Resolved

    We have now rolled out a fix, and players with MCC+ will get gems from the daily chest from the next time you open them. We'll send out the missed gems from today and yesterday shortly - keep an eye on your mailbox!

  • Identified
    UTC
    Identified

    We've identified the cause of this issue and are now working on a fix. We will reimburse every affected player once we've rolled out the fix.

  • Investigating
    UTC
    Investigating

    We're currently investigating an issue where players with MCC+ aren't getting their daily gems when they open the daily login chest. If this happens to you, please make a /bugreport and report it on the forums.