Scheduled for May 05, 2026 at 09:00 – 09:53
Affects
MCC Island Minecraft Server
Under maintenance from 9:00 AM to 9:53 AM
Completed
May 05, 2026 at 09:53Completed
May 05, 2026 at 09:53Maintenance has completed successfully and the patch is now live. We'll post the patch notes shortly. Thanks for your patience!
In progress
May 05, 2026 at 09:00In progress
May 05, 2026 at 09:00We will be shortly taking the network offline and the server will be unavailable whilst we make the backend changes for the update.
Planned
May 05, 2026 at 09:00Planned
May 05, 2026 at 09:00We are planning for a short period of downtime in order to roll out a series of backend changes that add support for 26.1.