MC Championship - Cherry Blossom event issues – Incident details

Cherry Blossom event issues

Resolved
Degraded performance
Started 2 days agoLasted about 17 hours

Affected

MCC Island Minecraft Server

Degraded performance from 11:06 PM to 4:30 PM

Updates
  • Resolved
    Resolved

    We've just pushed a patch live that addresses the issues mentioned below. We'll also shortly be sending out the apologmail compensation. Thank you for your patience and happy racing/hunting!

  • Investigating
    Investigating

    We're aware of the following issues with the Spirit Blossom update:
    - Daily Meter not giving any rewards.
    - Nearby players not hiding during Blossom Races.

    These issues will be fixed tomorrow, and we will be sending out compensation mailbox messages as an apology for the inconvenience. Otherwise, we hope you're enjoying the update!