MC Championship - Store purchases delayed – Incident details

Store purchases delayed

Resolved
Major outage
Started 2 days agoLasted about 3 hours

Affected

Websites

Major outage from 12:00 AM to 3:00 AM

MCC Island Webstore

Major outage from 12:00 AM to 3:00 AM

Updates
  • Resolved
    Resolved

    This incident has been resolved and all payments should now be working fine again.

  • Identified
    Identified

    We’re currently experiencing an issue with Tebex, the third-party service that processes store payments. As a result, store purchases cannot be processed at the moment. Any purchases made will be automatically completed within the next few hours once the issue is resolved.