Scheduled for March 05, 2026 at 10:30 – 10:48
Affects
MCC Island Minecraft Server
Under maintenance from 10:30 AM to 10:48 AM
Completed
March 05, 2026 at 10:48Completed
March 05, 2026 at 10:48Maintenance has completed successfully and the patch is now live. Thanks for your patience!
In progress
March 05, 2026 at 10:30In progress
March 05, 2026 at 10:30Maintenance is now in progress
Planned
March 05, 2026 at 10:30Planned
March 05, 2026 at 10:30We'll be taking the server offline for a short period of time in order to rollout a small patch with some backend changes. Matchmaking will be made unavailable shortly before the downtime.