Scheduled for February 09, 2026 at 10:00 – 12:40
Affects
MCC Island Minecraft Server
Under maintenance from 10:00 AM to 12:40 PM
Completed
February 09, 2026 at 12:40Completed
February 09, 2026 at 12:40Maintenance has completed successfully and the 0.30.2 update is now live. Thank you all for your patience!
Update
February 09, 2026 at 11:32Update
February 09, 2026 at 11:32We've increased the estimated downtime for the update rollout as it's taking slightly longer than we would have expected to do some general database cleanup. We'll keep you posted here how things are going, and thank you again for your patience!
In progress
February 09, 2026 at 10:16In progress
February 09, 2026 at 10:16We've now taken the network offline to roll out the update.
Planned
February 09, 2026 at 10:00Planned
February 09, 2026 at 10:00We will be taking the server offline for a short period of time in order to rollout an update that addresses backend issues with teleports to games failing.