Scheduled for October 15, 2024 at 12:30 – 12:36
Affects
MCC Island Minecraft Server
Completed
October 15, 2024 at 12:36Completed
October 15, 2024 at 12:36Maintenance has completed successfully.
In progress
October 15, 2024 at 12:30In progress
October 15, 2024 at 12:30Maintenance is now in progress
Planned
October 15, 2024 at 12:30Planned
October 15, 2024 at 12:30We'll be taking down the server for about 5 minutes to sort something out related to the recent server crashes. Matchmaking will be made unavailable shortly before the scheduled downtime.