Scheduled for October 07, 2024 at 13:00 – 13:04
Affects
MCC Island Minecraft Server
Completed
October 07, 2024 at 13:04Completed
October 07, 2024 at 13:04Update is out. Patch notes will be available shortly on the forums.
In progress
October 07, 2024 at 13:00In progress
October 07, 2024 at 13:00Maintenance is now in progress
Planned
October 07, 2024 at 13:00Planned
October 07, 2024 at 13:00We are planning for around an hour of downtime whilst we roll out our latest update. Matchmaking will be made unavailable shortly before the scheduled downtime.