MC Championship - Network connectivity issues – Incident details

Network connectivity issues

Resolved
Major outage
Started about 2 years agoLasted about 2 hours

Affected

MCC Island Minecraft Server

Major outage from 12:44 AM to 2:31 AM

Updates
  • Resolved
    Resolved

    This issue should be resolved now. The server is available and games are playable again.

  • Identified
    Identified

    An issue affecting a handful of our dedicated servers is unfortunately impacting crucial services required to run the network. At this point in time, MCC Island is unavailable, but we expect the network to be available again within the next 30 minutes.

  • Investigating
    Investigating

    We are currently investigating this incident where we're experiencing network connectivity issues affecting the majority of our servers. The network is currently unavailable.