MC Championship - BBA rank points – Incident details

BBA rank points

Resolved
Degraded performance
Started about 2 months agoLasted 2 days

Affected

MCC Island Minecraft Server

Degraded performance from 9:37 PM to 2:59 PM, Under maintenance from 2:59 PM to 3:56 PM, Degraded performance from 3:56 PM to 3:59 PM, Operational from 3:59 PM to 5:03 PM

Updates
  • Resolved
    Resolved

    The issue is now resolved. Sorry for the inconvenience and thank you all for your patience!

  • Update
    Update

    The fix is now fully live and we believe everything should be back to normal now. We will continue monitoring the state of the matchmaking and ranking systems in case we've missed anything else.

  • Monitoring
    Monitoring

    We've just deployed the fix now and the network is back online. We're now working on slowly getting the queues back online, so it may take 5-10 minutes before the matchmaking system becomes fully operational again.

  • Identified
    Identified

    We've identified the issue that is causing BBA rank points to go missing, and are working on a fix now. We've also identified another issue related to this that is now causing players in matchmaking queues to see that no servers are available. We will have to shortly take the network into maintenance mode in order to roll out a full fix for this issue.

  • Investigating
    Investigating

    We are currently investigating an infrequent issue that causes players to not gain/lose rank points in certain games of BBA. The team is actively investigating this situation, but as it is the weekend it is possible this won't be fixed until Monday.

    We're sorry for the inconvenience that is causing, and we hope to get a fix out as soon as possible!