MC Championship - Progression is lagging behind – Incident details

Progression is lagging behind

Resolved
Degraded performance
Started 14 days agoLasted about 2 hours

Affected

MCC Island Minecraft Server
Updates
  • Resolved
    Resolved

    A patch has been rolled out behind the scenes and progression is catching up quickly.

  • Investigating
    Investigating

    We are aware of an issue where progression may be lagging behind. It is being looked into. Your progress is not lost.