MCC Island Webstore experiencing degraded performance

Server unavailable

Resolved
Major outage
Started 4 months ago Lasted about 1 hour

Affected

MCC Island Minecraft Server
Updates
  • Resolved
    Resolved

    This issue should be resolved now and we're opening the network back up again.

  • Identified
    Identified

    The problem has been identified and a solution is still being worked on. We expect the server to be up within the next 30 minutes.

  • Investigating
    Investigating

    We're looking into issues with the server being unavailable.