MCC Island Webstore experiencing degraded performance

Networking issues

Resolved
Degraded performance
Started 6 months ago Lasted 41 minutes

Affected

MCC Island Minecraft Server
Updates
  • Resolved
    Resolved

    Traffic has been rerouted and the incident has now been resolved.

  • Monitoring
    Monitoring

    A fix has been implemented and we are currently monitoring the result.

  • Investigating
    Investigating

    We are currently investigating a networking issue that is causing the server to be unavailable for some UK/EU players.