MCC Island Webstore experiencing degraded performance

Halloween hunt not working

Resolved
Degraded performance
Started 6 months ago Lasted 25 minutes

Affected

MCC Island Minecraft Server
Updates
  • Resolved
    Resolved

    We've rolled out the fix for this and the chest and stashes have returned! Happy hunting :)

  • Identified
    Identified

    We've identified the cause of this problem and are rolling out a fix now. The main lobbies will shortly be restarting and the hunt will be back on soon!

  • Investigating
    Investigating

    We are currently investigating an issue that is causing the stashes and chests for today's Halloween hunt to not appear. The team are actively working on this issue and should have a fix rolled out soon!