MCC Island Webstore experiencing degraded performance

Degraded Event API Performance

Resolved
Major outage
Started 7 months ago Lasted about 18 hours

Affected

API
MCC Event API
Updates
  • Resolved
    Resolved

    We believe the incident to now be resolved. We will continue monitoring in case anything changes. Thank you for your patience!

  • Monitoring
    Monitoring

    A potential fix has been deployed and we are monitoring the results.

  • Identified
    Identified

    A potential issue has been identified and we are working on a fix now.

  • Investigating
    Update

    The API is now undergoing a severe outage.

    We are continuing to search for a potential fix to this issue. Due to the time of day, many of our team members are unavailable, so it may take longer than usual for this to be resolved. We appreciate your patience, and we'll update here as soon as we can.

  • Investigating
    Investigating

    The MCC Event API is intermittently returning HTTP 503 errors. We are investigating this issue and will report back here as soon as possible.