MCC Island Webstore experiencing degraded performance

Elevated declined payments

Resolved
Operational
Started 9 months ago Lasted about 6 hours

Affected

Websites
MCC Island Webstore
Updates
  • Resolved
    Resolved

    Tebex has indicated that this has now been resolved.

  • Monitoring
    Monitoring

    Tebex has indicated that things are returning to normal. We continue to be in communication with them awaiting a concrete resolution.

  • Identified
    Identified

    Our webstore provider, Tebex, is experiencing issues which may cause higher than usual levels of declined payments.