MCC Island Webstore experiencing degraded performance

Server issues

Resolved
Major outage
Started 10 months ago Lasted about 1 hour

Affected

MCC Island Minecraft Server
Updates
  • Resolved
    Resolved

    The fix that we rolled out is stable and we have restored the player count back to normal. Thank you all for your patience!

  • Monitoring
    Update

    The fix appears to be stable and we are now beginning the process of slowly raising the player cap.

  • Monitoring
    Monitoring

    The server is now back online with a reduced player cap whilst we monitor the side effects of the fix to make sure that the server is running smoothly. If everything is performing okay, we will slowly raise the player cap back to its initial value.

  • Identified
    Update

    We have identified and implemented a fix for the issue and are currently working on bringing the network back online again. We cannot give an exact time that it will be back online, but it shouldn't be too long now!

  • Identified
    Identified

    We've identified the cause of the issues in server performance and stability and are working hard to get a fix implemented. The server will remain offline whilst we implement and roll out the fix. At this time we do not have an ETA for when the server will be back online, but we do not expect it to take too long.

  • Investigating
    Investigating

    We are currently investigating an issue that is causing server performance and stability to be severely degraded. In order to identify the cause and fix this as soon as possible, we are temporarily taking the server offline.