MCC Island Webstore experiencing degraded performance

Statistics & progression may be delayed

Resolved
Degraded performance
Started 11 months ago Lasted 1 day

Affected

MCC Island Minecraft Server
Updates
  • Resolved
    Update

    Statistics are lagging behind again. We're looking into resolving this.

  • Resolved
    Resolved

    We're no longer seeing abnormal amounts of statistics lag. This issue should be resolved.

  • Monitoring
    Monitoring

    We have implemented a potential fix for this. We expect queued up statistics to be processed within 2 hours.

  • Investigating
    Investigating

    Game systems like badges, leaderboards, game mastery etc. that rely on your in-game statistics may be heavily delayed.

    You will not lose any of your statistics or progress.