MCC Island Webstore experiencing degraded performance

Statistics & progression may be delayed

Resolved
Degraded performance
Started 11 months ago Lasted about 9 hours

Affected

MCC Island Minecraft Server
Updates
  • Resolved
    Resolved

    We've caught up with all of the statistics, they should no longer be delayed.

  • Identified
    Identified

    Game systems like badges, leaderboards, game mastery etc. that rely on your in-game statistics may be heavily delayed.

    You will not lose any of your statistics or progress.