MCC Island Webstore experiencing degraded performance

Admission ticket & forum emails may not be functional

Resolved
Partial outage
Started over 1 year ago Lasted about 4 hours

Affected

Websites
Forums
Newsletters
Updates
  • Resolved
    Resolved

    The third-party provider involved has resolved this issue.

  • Identified
    Identified

    A third-party provider used for sending emails is currently experiencing issues. This may prevent you from claiming admission tickets or signing up for the beta wait list. We do not have an ETA on a fix for this.