Scheduled for March 12, 2026 at 14:30 – 22:00
Affects
MCC Island Minecraft Server
Under maintenance from 2:30 PM to 12:00 AM
Update
March 12, 2026 at 21:28Update
March 12, 2026 at 21:28Final testing is in progress.
We will be back asap. So so sorry for the continued delays
Update
March 12, 2026 at 20:45Update
March 12, 2026 at 20:45Hi all, we're really close to launch, we just need an extra 30 minutes to finalise everything
Thank you for your patience!
Update
March 12, 2026 at 17:05Update
March 12, 2026 at 17:05We've pushed the maintenance period end time back slightly whilst the team works on fixes for the backend hardware issues that occurred the other day. Rest assured we're still hard at work on the finishing touches and we will get the update live for you to play with as soon as we can!
Thank you for your patience <3
Update
March 12, 2026 at 17:05Update
March 12, 2026 at 17:05We've pushed the maintenance period end time back slightly whilst the team works on fixes for the backend hardware issues that occurred the other day. Rest assured we're still hard at work on the finishing touches and we will get the update live for you to play with as soon as we can!
Thank you for your patience <3
In progress
March 12, 2026 at 14:30In progress
March 12, 2026 at 14:30Maintenance is now in progress
Planned
March 12, 2026 at 14:30Planned
March 12, 2026 at 14:30We are planning for a scheduled maintenance during this time in order to roll out our latest event. Matchmaking will be made unavailable shortly before this time.