MC Championship - Unexpected downtime – Incident details

Unexpected downtime

Resolved
Major outage
Started about 17 hours agoLasted about 9 hours

Affected

MCC Island Minecraft Server

Major outage from 3:00 AM to 12:08 PM

API

Major outage from 3:00 AM to 12:08 PM

MCC Island API

Major outage from 3:00 AM to 12:08 PM

Updates
  • Resolved
    Resolved

    We've got some new hardware to replace the old broken ones and the network is back online. We've retained any missed daily streaks from yesterday and you will also find some downtime compensation in your mailbox.

    Sorry for the inconvenience and thank you for your patience!

  • Identified
    Identified

    We've identified the cause of this issue, which is a hardware issue that is unfortunately out of our control. We're working with our hardware provider to fix the affected server to bring the network back online. Unfortunately, we don't have an ETA at this time, but rest assured we're doing our best to get Island back online!

  • Investigating
    Investigating

    We are currently investigating an issue that has caused players to be disconnected from the network and unable to join.