Scheduled for January 16, 2025 at 09:15 – 09:25
Affects
MCC Island Minecraft Server
Under maintenance from 9:15 AM to 9:25 AM
Completed
January 16, 2025 at 09:25Completed
January 16, 2025 at 09:25Maintenance is complete and the server is back up.
In progress
January 16, 2025 at 09:15In progress
January 16, 2025 at 09:15Maintenance is now in progress
Planned
January 16, 2025 at 09:15Planned
January 16, 2025 at 09:15We'll be taking down the server for a short period of time to prevent some of the recent server stability issues from happening again. Matchmaking will be made unavailable shortly before the scheduled downtime.