MC Championship - Connection issues – Incident details

Connection issues

Resolved
Degraded performance
Started 4 months agoLasted about 2 hours

Affected

MCC Island Minecraft Server
Updates
  • Resolved
    Resolved

    This incident seems to be resolved currently. We'll be monitoring throughout the day.

  • Identified
    Identified

    We're currently experiencing some issues with our backend networking. The team is hard at work to find a solution. In the meantime, you may experience some lag or random disconnects whilst playing.