Scheduled for December 11, 2025 at 11:30 – 21:00
Affects
MCC Island Minecraft Server
Under maintenance from 11:30 AM to 9:00 PM
API
Under maintenance from 11:30 AM to 9:00 PM
MCC Island API
Under maintenance from 11:30 AM to 9:00 PM
Completed
December 11, 2025 at 21:00Completed
December 11, 2025 at 21:00Maintenance has completed successfully and the Battle Box Arena update is now live. We're still working on some issues, and will update the status page with more information shortly.
Thank you for your patience!
Update
December 11, 2025 at 16:24Update
December 11, 2025 at 16:24We're still working hard on the rollout for Battle Box Arena.
We're extending the estimated time the server will be back online slightly as it's coming closer to the previous estimation and we're still a few hours to go. Keep checking the status page for more updates and thank you all for your patience!
For more information about downtime, check out our Support page article.
In progress
December 11, 2025 at 11:32In progress
December 11, 2025 at 11:32MCC Island is now offline in order to rollout the Battle Box Arena update. We currently estimate this will last around 6 hours, but it may take longer or shorter.
This downtime is required as we are rolling out some major backend updates to the server systems, including matchmaking and more.
For more information about downtime, check out our Support page article.
Planned
December 11, 2025 at 11:30Planned
December 11, 2025 at 11:30We are planning some downtime in order to rollout the Battle Box Arena update. We currently estimate this will last around 6 hours, but it may take longer or shorter.
This downtime is required as we are rolling out some major backend updates to the server systems, including matchmaking and more.
For more information about downtime, check out our Support page article.