Scheduled for June 17, 2025 at 09:15 – 09:46
Affects
MCC Island Minecraft Server
Under maintenance from 9:15 AM to 9:46 AM
Completed
June 17, 2025 at 09:46Completed
June 17, 2025 at 09:46The update is now live. Thank you for your patience!
In progress
June 17, 2025 at 09:15In progress
June 17, 2025 at 09:15Maintenance is now in progress.
Planned
June 17, 2025 at 09:15Planned
June 17, 2025 at 09:15We will have a short period of downtime in order to update our network to support 1.21.6 for when it releases. Matchmaking will be taken offline 15 minutes prior to the downtime.